Introducao

Introdução


Apresentacao

Apresentação
 Previous Top Next
OPT GISTLight

O sistema GISTLight é um software que permite gerir a informação base relativa à rede de transportes, às linhas e às viagens a realizar. Permitem ainda gerar, de uma forma optimizada, os serviços das viaturas e dos motoristas.
Para alguns dos problemas tratados foram desenvolvidos procedimentos algorítmicos optimizantes e heurísticos, que são propostos ao planeador como possíveis alternativas.


Conceitos

Conceitos usados no GISTLight:

Nó – Um nó é um ponto da rede de transportes com importância para o processo de planeamento. Exemplos de nós são estações de recolha e paragens ao público, embora nem todos os pontos pertencentes a estas categorias (em especial, as paragens) dêem origem a nós.

Estação de recolha - Uma estação de recolha é um local (normalmente pertencendo à empresa) onde é feito o estacionamento das viaturas que não estão a ser utilizadas.

Ponto de Rendição - Um ponto de rendição é um nó onde é possível render tripulações. As estações de recolha são implicitamente consideradas pontos de rendição.

Términos - Um término é um local de início e/ou de fim de viagem

Tempo de deslocação - Tempo que um tripulante necessita para se deslocar de um ponto de rendição para outro.

Percurso – Um percurso é um trajecto entre dois nós.

Linha – Uma linha corresponde a um conjunto de percursos entre dois pontos que irá dar origem a um horário ao público. Normalmente uma linha terá, pelo menos, dois percursos em sentidos opostos, e por vezes poderá ter percursos mais pequenos que permitem reforçar a oferta em algumas das áreas cobertas pela linha.

Viagem – Uma viagem é a definição de horário do percurso

Hora de Passagem – A hora de passagem indica a hora em que uma viagem deve passar num determinado nó.

Pontos de Informação - Um pontos de informação é um aspecto relevante num determinado nó para uma determinada hora.

Bloco de Trabalho – Um bloco de trabalho é um conjunto de viagens feitas, sem interrupções pela mesma viatura, e com ou sem interrupções pelo mesmo Tripulante (tripulação).

Serviço de Tripulante – Um serviço de Tripulante corresponde ao período diário de uma tripulação. Um serviço é definido como uma sequência de blocos de trabalho obedecendo a um conjunto de regras.

Etapa – Uma etapa é um período de tempo sem interrupções em que uma tripulação ou viatura está ao serviço da empresa. Um serviço pode ter uma ou mais etapas, sendo os casos mais habituais os serviços de uma etapa (ou seguidos), duas etapas e três etapas.

Tipo de Serviço – Um tipo de serviço classifica um serviço em função de um conjunto de regras a que esse serviço deve obedecer.

Parâmetros Globais de Serviços – Os parâmetros globais de serviços são um conjunto de regras e custos que se aplicam a todos os serviços independentemente do seu tipo.

Serviço de Viatura – Um serviço de viatura corresponde ao trabalho a realizar ou realizado por uma viatura. Este serviço pode corresponder a um turno do horário de viaturas ou a um serviço do horário de serviços.

Rede - Conjunto de todos os elementos que fazem parte da rede de planeamento: nós, percursos, linhas, e tipos de viatura.

Horário - Conjunto de todos os elementos que fazem parte do horário: viagens, serviços de viatura, servi-ços de tripulante, tipos de serviço de tripulante.

WGS84 - O WGS84 (World Geodetic System) é um standard usado na cartografia, geodesia e navegação. É a referência de sistema de coordenadas utilizado pelo Sistema de Posicionamento Global (GPS). Limites: -180.0000, -90.0000, 180.0000, 90.0000


Tipos de Condicões

Tipos de Condições
Os Tipos de Condições disponíveis:
Tipo de dados | Tipo de Condição
Numéricos | Igual (=)
 | Diferente (<>)
 | Maior que(>)
 | Maior ou igual (>=)
 | Menor que (<)
 | Menor ou igual (>=)
Texto | Igual(=)
 | Diferente(<>)
 | Depois de (>)
 | Antes de (<)
 | Igual ou depois de (>),
 | Igual ou antes de (<)
 | Começa com (>>)
 | Contém (>><<)
Outros | Igual(=)
 | Diferente(<>)


Operadores Logicos

Operadores Lógicos
Os Operadores Lógicos são aplicáveis a condições e/ou (sub-) filtros, são eles:

· E- todas as condições/ (sub-) filtros tem que ser válidos.

· Ou - pelo menos uma condições/ (sub-) filtros tem que ser válido.

· Não - permite negar uma condição/ (sub-) filtro.


Menu da Aplicacao

Menu da Aplicação
O Menu da Aplicação é constituído por:

· Novo (Ctrl+N)
· Abrir (Ctrl+O)
· Guardar (Ctrl+S)
· Guardar Como
· Imprimir
· Importar
· Exportar
· Fechar (Ctrl+F4)
· Opções
· Sair do GIST light
· Documentos Recentes

Funcionalidades do menu:

Novo permite abrir um novo documento vazio.

Abrir permite abrir um documento existente.

Guardar permite guardar as alterações efectuadas num documento já aberto.

Guardar Como permite guardar o documento numa determinada directoria, com possibilidade de atribuir novo nome.

Importar permite importar partes de dados para o documento aberto.

Exportar permite imprimir o partes de dados do documento aberto.

Imprimir permite imprimir o documento.

Fechar permite fechar o documento aberto.

Documentos Recentes consiste numa listagem dos últimos documentos abertos.

Opções dispõem:

Separador Geral:
· Definir o modo de Inserção das Viagens e dos Pontos de Informação. Se estiver seleccionado, a inserção é feita item a item. Caso contrário, é feita inserção múltipla, até o utilizador terminar o modo de inserção ou carregar na tecla Esc.
· Voltar às definições iniciais.

Separador Recursos:

· Obter as últimas actualizações do GISTLight.
· Contactar a OPT para obter ajuda ou fornecer alguma sugestão.
· Ir para o OPT GISTLight Online.
· Obter informações sobre o GISTLight.

Sair do GISTLight permite fechar a aplicação.


Menu de Acesso Rapido

Menu de Acesso Rápido
O Menu de Acesso Rápido é constituído por:

· Guardar (Ctrl+S)
· Anular (Ctrl+Z)
· Refazer (Ctrl+Y)

Funcionalidades do menu:

Guardar permite guardar as alterações no documento.

Anular permite anular a última alteração no documento.

Refazer permite refazer a última alteração no documento.


Menu de Rede

Menu de Dados
O Menu de Rede é constituído por:

· Mapa
· Mapa
· Dados
· Nós
· Tempos de Deslocação da Tripulação
· Percursos
· Linhas
· Tipos de Viatura

Funcionalidades do menu:

Mapa:

Mapa permite visualizar a janela de Mapa.

Dados:

Nós permite visualizar a janela de lista de Nós.

Tempos de Deslocação da Tripulação permite visualizar a janela de lista de Tempos de Deslocação.

Percursos permite visualizar a janela de lista de Percursos.

Linhas permite visualizar a janela de lista de Linhas.
Tipos de Viatura permite visualizar a janela de lista de Tipos de Viatura.

Horários:

Serviços de Tripulante permite visualizar a janela de lista de Serviços de Tripulante.

Métricas permite visualizar a janela com as métricas aplicadas aos parâmetros dos serviços de tripulante.


Menu de Viagens

Menu Inserir
O Menu Viagens é constituído por:

· Dados
· Viagens
· Viagens
· Viagem
· Viagem Vazia
· Ponto de Informação
· Ver
· Estilo
· Cor
· Mais Zoom
· Menos Zoom
· Ajustar
· Vertical
· Ajustar
· Pontos de informação e guias
· Ordenação Automática
· Ordenação Manual
· Filtrar Linhas
· Filtrar Serviços de Viatura

Funcionalidades do menu:

Dados:
Viagens permite visualizar a janela de lista de Viagens.

Inserir:

Viagem permite criar uma viagem normal na área de trabalho dos horários de viagens.

Passos a efectuar:

1. Clicar no botão Viagem;

2. Na área de trabalho dos horários de viagens (usando o botão do lado esquerdo do rato) definir a primeira hora de passagem da viagem;

3. De seguida, deve clicar novamente na área de trabalho dos horários de viagens (usando o botão do lado esquerdo do rato) e este ponto é considerado como a última hora de passagem da viagem.

Se existir um percurso que satisfaça esta selecção será apresentado uma janela de edição da viagem.

4. Na janela de edição da viagem devem ser definidas todas as características da viagem.

5. Deve pressionar o botão Ok para confirmar a criação da viagem ou o botão Cancelar para cancelar a criação da viagem.

Nota: Durante a criação da viagem é possível cancelar a sua criação, para isso pressione o botão ESC do seu teclado ou volte a clicar no botão Viagem.

Viagem Vazia permite criar uma viagem vazia na área de trabalho dos horários de viagens.

Passos a efectuar:
1. Clicar em Viagem;

2. Na área de trabalho dos horários de viagens (usando o botão do lado esquerdo do rato) definir a primeira hora de passagem da viagem em vazio;

3. De seguida, deve clicar novamente na área de trabalho dos horários de viagens (usando o botão do lado esquerdo do rato) e este ponto é considerado última hora de passagem da viagem.

Se existir um percurso que satisfaça esta selecção será apresentado uma janela de edição da viagem.

4. Na janela de edição da viagem devem ser definidas todas as características da viagem.

5. Deve pressionar o botão Ok para confirmar a criação da viagem ou o botão Cancelar para cancelar a criação da viagem.

Nota: Durante a criação da viagem em vazio é possível cancelar a sua criação, para isso pressione o botão ESC do seu teclado ou volte a clicar no botão Viagem em Vazio.

Ponto de Informação permite criar um ponto de informação na área de trabalho do horário de viagens.

Passo a efectuar:

1. Clicar em Ponto de Informação;

2. Clicar na área na área de trabalho do horário de viagens (usando o botão do lado esquerdo do rato);

3. Será apresentado a janela de criação do ponto de informação, onde será definido as características deste ponto.

4. Deve pressionar o botão Ok para confirmar a criação do ponto de informação ou o botão Cancelar para cancelar a criação do ponto de informação.

Nota: Durante a criação do Ponto de Informação é possível cancelar a sua criação, para isso pressione o botão ESC do seu teclado ou volte a clicar no botão Ponto de Informação.

Ver:

Estilo permite definir o estilo de todas viagens, os estilos possíveis são de Linha Recta e Linha Quebrada.
Um estilo de linha recta é a linha que une a primeira hora de passagem da viagem com a última hora de passagem, ocultando os restantes pontos/horas de passagem, e um estilo de linha quebrada é a linha que une todas as horas de passagem da viagem.

Cor permite definir a cor das viagens: Cor dos Serviços de Viatura, Cor dos Serviços de Tripulante e Cor da Linha.
Se estiver seleccionada Cor da Linha, a cor das viagens é definida pela cor da sua Linha;
Se estiver seleccionada Cor dos Serviços de Tripulante, a cor das viagens é definida pela cor do seu Serviço de Tripulante;
Se estiver seleccionada Cor dos Serviços de Viaturas, a cor das viagens é definida pela cor do seu Serviço de Viatura;
Mais Zoom permite aumentar o detalhe do horário das viagens (vertical).

Menos Zoom permite diminuir o detalhe do horário das viagens (vertical).

Ajustar verticalmente distribui a altura que existe no controlo gráfico de viagens pelos nós.

Ajustar aplica o Ajustar verticalmente (anterior) e o Ajustar horizontalmente das horas.

Pontos de Informação se estiver seleccionada os pontos de informação serão apresentados na área de trabalho dos horários de Viagens, caso contrário serão ocultados.

Linhas guia de horas se estiver seleccionada são mostradas as linha dos eixos de horas na área de trabalho dos horários das Viagens, caso contrário são ocultadas.

Linhas guia dos nós se estiver seleccionada são exibidas as linha horizontais de cada nó, caso contrário são ocultadas.

Ordenação Automática procura para todos os nós e viagens que sejam visíveis efectuar o menor número de saltos entre os nós, ou seja, procura colocar as linhas na forma mais rectilí-nea possível.

Ordenação manual permite ao utilizador trocar a ordem (e estabelecer visibilidades) dos nós através de uma lista. Deve seleccionar um nó na lista e utilizar os botões de mover Para cima ou Para baixo, quando terminar <Clique Esq> em Ok para aceitar as alterações, ou no botão Cancelar para cancelar as alterações.

Filtrar Linhas a parte inferior permite visualizar a listagem de todas as linhas e seleccionar a linha ou as linhas que se pretende visualizar na área de trabalho dos horários das Viagens, sendo possível desseleccionar alguma das linhas seleccionada. Para limpar esta selecção e se poder ver todas as viagens de todas as linhas deve-se clicar na parte superior.

Filtrar Serviços de Viatura a parte inferior permite visualizar a listagem de todos os serviços de viatura e seleccionar a linha ou as linhas que se pretende visualizar na área de trabalho dos horários das Viagens, sendo ainda possível desseleccionar alguma das linhas seleccionada.
Para limpar esta selecção e ver todas as viagens de todos os serviços de viatura deve-se clicar na parte superior.


Menu de Viaturas

Menu Ver
O Menu Viaturas é constituído por:

· Dados
· Serviços de Viatura
· Editar
· Bloco de Trabalho
· Auto ajustar Serv. de Viatura
· Ver
· Mais Zoom
· Menos Zoom
· Ajustar
· Vertical
· Ajustar
· Linas guia de horas
· Ordenação Manual
· Validação automática

Funcionalidades do menu:

Dados:

Serviços de Viatura permite visualizar a janela de lista de Serviços de Tripulante..

Editar:

Bloco de Trabalho permite criar um bloco de trabalho na área de trabalho do horário de Serviços de Tripulante ou no horário de Serviços de Viaturas.

Passo a efectuar:

1. Clicar em Blocos de Trabalho

2. Entrar na área de trabalho (gráfico) dos horários de Serviços de Viatura;

3. Clicar na área de trabalho (usando o botão do lado esquerdo do rato e manter o botão do rato pressionado ) para iniciar a criação do bloco. Neste ponto é definida a hora de início da porção de trabalho.

4. Arrastar o rato e voltar a clicar na área de trabalho para definir a hora de fim do bloco de trabalho.

5. Será apresentado uma janela de criação da bloco de trabalho, onde será definido todas as características.

6. Deve pressionar o botão Ok para confirmar a criação do bloco de trabalho ou o botão Cancelar para cancelar a criação.

Nota: Durante a criação da Bloco de Trabalho é possível cancelar a sua criação, para isso pressione o botão ESC do seu teclado ou volte a clicar no botão Bloco de Trabalho.

Auto ajustar Serv. de Viatura caso esteja activado quando elimina uma viagem de um bloco de trabalho, este é ajustado para a viagem anterior ou seguinte (dependedo da ponta do bloco de trabalho onde a viagem se encontre), se existir, caso contrário (bloco resultante sem viagens) elimina a viagem. Se a opção não estiver seleccionada apenas remove a viagem do bloco.

Ver:

Mais Zoom permite aumentar o detalhe do horário dos Serviços de Viatura (vertical).

Menos Zoom permite diminuir o detalhe do horário dos Serviços de Viatura (vertical).

Ordenação manual permite ao utilizador trocar a ordem (e estabelecer visibilidades) dos serviços de Viatura através de uma lista. Deve seleccionar um serviço de Viatura na lista e utilizar os botões de mover Para cima ou Para baixo, quando terminar <Clique Esq> em Ok para aceitar as alterações, ou no botão Cancelar para cancelar as alterações.

Linhas guia de horas se estiver seleccionada são mostradas as linha dos eixos de horas na área de trabalho dos horários dos Serviços de Viatura, caso contrário são ocultadas.

Extremos dos blocos de trabalho se estiver seleccionado o gráfico de serviços de Viaturas exibe nas extremidades dos blocos de trabalho os nós, caso contrário estes são ocultados, libertando espaço visual.

Ajustar verticalmente distribui a altura que existe no controlo gráfico de viagens pelos nós.

Ajustar aplica o Ajustar verticalmente (anterior) e o Ajustar horizontalmente das horas.

Validação automática permite visualizar a janela de validação automática dos serviços, com informação útil para a manipulação de serviços.


Menu de Tripulantes
O Menu Viaturas é constituído por:

· Dados
· Tipos de Serviço de Tripulante
· Serviços de Viatura
· Métricas
· Editar
· Bloco de Trabalho
· Auto ajustar Serv. de Viatura
· Ver
· Mais Zoom
· Menos Zoom
· Ajustar
· Vertical
· Ajustar
· Linas guia de horas
· Ordenação Manual
· Validação automática

Dados:

Tipos de Serviço de Tripulante permite visualizar a janela de lista de Tipos de Serviço. de Tripulante.

Serviços de Viatura permite visualizar a janela de lista de Serviços de Tripulante..

Métricas permite visualizar a janela com as métricas dos Serviços de Tripulante.

Editar:

Bloco de Trabalho permite criar um bloco de trabalho na área de trabalho do horário de Serviços de Tripulante ou no horário de Serviços de Viaturas.

Passo a efectuar:

1. Clicar em Blocos de Trabalho

2. Entrar na área de trabalho (gráfico) dos horários de Serviços de Tripulante;

3. Clicar na área de trabalho (usando o botão do lado esquerdo do rato e manter o botão do rato pressionado ) para iniciar a criação do bloco. Neste ponto é definida a hora de início da porção de trabalho.

4. Arrastar o rato e voltar a clicar na área de trabalho para definir a hora de fim do bloco de trabalho.

5. Será apresentado uma janela de criação da bloco de trabalho, onde será definido todas as características.

6. Deve pressionar o botão Ok para confirmar a criação do bloco de trabalho ou o botão Cancelar para cancelar a criação.

Nota: Durante a criação da Bloco de Trabalho é possível cancelar a sua criação, para isso pressione o botão ESC do seu teclado ou volte a clicar no botão Bloco de Trabalho.

Auto ajustar Serv. de Tripulante caso esteja activado quando elimina uma viagem de um bloco de trabalho, este é ajustado para a viagem anterior ou seguinte (dependedo da ponta do bloco de trabalho onde a viagem se encontre), se existir, caso contrário (bloco resultante sem viagens) elimina a viagem. Se a opção não estiver seleccionada apenas remove a viagem do bloco.

Ver:
Mais Zoom permite aumentar o detalhe do horário dos Serviços de Tripulante (vertical).

Menos Zoom permite diminuir o detalhe do horário dos Serviços de Tripulante (vertical).

Ordenação manual permite ao utilizador trocar a ordem (e estabelecer visibilidades) dos serviços de tripulante através de uma lista. Deve seleccionar um serviço de tripulante na lista e utilizar os botões de mover Para cima ou Para baixo, quando terminar <Clique Esq> em Ok para aceitar as alterações, ou no botão Cancelar para cancelar as alterações.

Linhas guia de horas se estiver seleccionada são mostradas as linha dos eixos de horas na área de trabalho dos horários dos Serviços de Tripulante, caso contrário são ocultadas.

Extremos dos blocos de trabalho se estiver seleccionado o gráfico de serviços de tripulantes exibe nas extremidades dos blocos de trabalho os nós, caso contrário estes são ocultados, libertando espaço visual.

Ajustar verticalmente distribui a altura que existe no controlo gráfico de viagens pelos nós.

Ajustar aplica o Ajustar verticalmente (anterior) e o Ajustar horizontalmente das horas.

Validação automática permite visualizar a janela de validação automática dos serviços, com informação útil para a manipulação de serviços.


Menu Parametrizacao

Menu Parametrização

O Menu de Dados é constituído por:

· Parâmetros Globais
· Parâmetros Dinâmicos

Funcionalidades do menu:

Parâmetros Globais permite visualizar a janela de Parâmetros Globais.

Parâmetros Dinâmicos permite visualizar a janela de lista de Parâmetros Dinâmicos.


Menu Horario

Menu Horário
O Menu de Horário é constituído por:

· Ver
· Mais Zoom
· Menos Zoom
· Redimensionar ao mover
· Ajustar horizontalmente
· Ajustar

Funcionalidades do menu:

Horas:

Mais Zoom permite aumentar o detalhe das horas (horizontal).

Menos Zoom pemite diminuir o detalhe das horas (horizontal).

Redimensionar ao mover Se opção estiver seleccionada, visualiza a todo o instante o resultado final do redimensiona-mento, Caso contrário, quando estiver a fazer um redimensionamento de qualquer uma das horas, irá ver uma pequena barra preta que indica o local onde pretende colocar o extremo que seleccionou para redimensionar.

Ajustar Horizontalmente distribui a largura que existe nos controlo gráfico (horas).

Ajustar distribui a altura e largura(horas) que existem em todos os controlos gráficos.


Menu de Geracao Automatica

Menu de Geração Automática
O Menu Geração Automática é constituído por:

· Serviços
· Deslocação Tripulantes
· Blocos de Trabalho

· Algoritmos
· Geração de serviços de Viatura (Básico)
· Geração de serviços de Viatura (AntColony)
· Geração de serviços de Tripulante (GenT)

Funcionalidades do menu:

Serviços:

Deslocação Trip. - gera os blocos de trabalho necessários aos serviços de tripulante para fazer a deslocação entre os términos.

Blocos de Trab. - quebra todos os blocos de trabalho dos serviços de viatura utilizando um tempo mínimo de intervalo entre os pontos de rendição.

Algoritmos de Serviço de Viatura:

Básico - geração de serviços de viatura com recurso ao algoritmo básico (não considera as restrições de tipos de viatura nas viagens).

AntColony - geração de serviços de viatura com recurso ao algoritmo AntColony (com restrições tipos de viatura nas viagens).

Algoritmos de Serviço de Tripulante:

GenT - geração de serviços de tripulante com recurso ao algoritmo GenT.


Menu de Relatorios

Menu de Relatórios
O Menu Relatórios é constituído por:

· Serviços de Viatura
· Horários por Serviço de Viatura
· Viagens por Serviço de Viatura

· Serviços de Tripulante
· Horários por Serviço de Tripulante
· Viagens por Serviço de Tripulante

· Propriedades por Serviço de Tripulante
· Custos
· Rede
· Horários por Linha
· Horários por Nó

(Nota: Alguns horários podem não estar disponíveis, consulte o nosso site para saber quais os horários disponíveis para a versão que tem instalada.)

Funcionalidades do menu:

Serviços de Tripulante:

Horários por Serviço de Tripulante permite seleccionar um ou mais Serviços de Tripulante e gerar o relatório dos horários desses serviços. Contém a informação dos blocos de trabalho que existem no serviços seleccionados.

Viagens por Serviço de Tripulante permite seleccionar um ou mais Serviços de Tripulante e gerar o relatório das viagens desses serviços. É apresentado um resumo do serviço, e para cada viagem os dados de início e fim, serviços associado e o detalhe das horas de passagem das viagens.

Propriedades por Serviço de Tripulante permite seleccionar um ou mais Serviços de Tripulante e gerar o relatório com a informação das propriedades (como por exemplo número de etapas, tempos de trabalho,...) e de validação dos serviços.

Serviços de Viatura:

Horários por Serviço de Viatura permite seleccionar um ou mais Serviços de Viatura e gerar o relatório dos horários desses serviços. Contém a informação dos blocos de trabalho que existem no serviços seleccionados.

Viagens por Serviço de Viatura permite seleccionar um ou mais Serviços de Viaturae gerar o relatório das viagens desses serviços. É apresentado um resumo do serviço, e para cada viagem os dados de início e fim, serviços associado e o detalhe das horas de passagem das viagens.

Linhas:

Horários por Linha permite seleccionar uma ou mais Linhas e gerar o relatório de horários dessas linhas, organizada por linha e orientação de viagem

Horários por Nó permite seleccionar um ou mais Nós e gerar o relatório de horários desses nós, contendo a informação das horas de passagem no nó, organizada por linha.


Menu de Visualizacao de Horarios

Menu de Vizualização de Horários
O Menu de Visualização de Horários é constituído por:
(canto inferior direito)

· Ver horário de Serviços de Motorista
· Ver horário de Serviços de Viatura
· Ver horário de Viagens
· Ver horário de Serviços de Viatura e de Motorista
· Ver horário de Serviços de Viatura, Motorista e Viagens
· Ver horário de Serviços de Motorista e Viagens
· Ver horário de Serviços de Viaturas e Viagens

Funcionalidades do menu:

Ver horário de Serviços de Motorista maximiza a área de trabalho de Serviços de Motorista e oculta a área de trabalho de Viagens e de Serviços de Viatura.
Atalho de Teclado: <Ctrl> + <1>

Ver horário de Serviços de Viatura maximiza a área de trabalho de Serviços de Viatura e oculta a área de trabalho de Viagens e de Serviços de Motorista.
Atalho de Teclado: <Ctrl> + <2>

Ver horário de Viagens maximiza a área de trabalho de Viagens e oculta a área de trabalho de Serviços de Viatura e de Serviços de Motorista.
Atalho de Teclado: <Ctrl> + <3>

Ver horário de Serviços de Viatura e de Motorista maximiza equitativamente a área de trabalho de Serviços de Motorista e de Viaturas, e oculta a área de trabalho de Viagens.
Atalho de Teclado: <Ctrl> + <4> (Opção seleccionada na imagem).

Ver horário de Serviços de Motorista e Viagens maximiza equitativamente a área de trabalho de Serviços de Motorista e das Viagens, e oculta a área de trabalho de Serviços de Viatura.
Atalho de Teclado: <Ctrl> + <5>

Ver horário de Serviços de Viaturas e Viagens maximiza equitativamente a área de trabalho de Serviços de Viatura e de Viagens, e oculta a área de trabalho de Serviços de Motorista.
Atalho de Teclado: <Ctrl> + <6>

Ver horário de Serviços de Viatura, Motorista e Viagens maximiza equitativamente a área de trabalho de Serviços de Motorista, Viaturas e de Viagens.
Atalho de Teclado: <Ctrl> + <7>


Horario de Viagens

Horário de Viagens
O Horário de Viagens está colocado na parte inferior da área de trabalho da aplicação.

Contempla o desenho de viagens, que são posicionadas nos eixos horário (horizontal) e de nós (vertical).

As viagens em vazio são desenhadas com linha tracejada, enquanto que as viagens normais são desenhadas com linha a cheio.

Os terminos de cada viagem são realçados com um círculo preto.

A representação de viagens é feita de uma de duas formas: linha normal ou linha segmentada.

No caso de linha normal, só são exibidas os dois terminos e a linha que os une.

No caso de linha segmentada, a linha une todos as horas de passagem.

Se clicar sobre uma viagem passa a visualizar todas as horas de passagem que compõem a visualização activada da viagem, e também alguma informação no canto inferior esquerdo:
Linha | Percurso | Hora de Início - Hora de Fim | Duração.

As interacções gráficas disponíveis são:
· Arrastar viagem(ns)
· Arrastar Hora de Passagem (quando viagem seleccionada)
· Adicionar Viagens a Serviço de Viatura ou Serviço de Tripulante
· Copiar e Colar Viagens
· Opções do menu de contexto (botão direito rato sobre viagem)
· Ctrl+C e Ctrl+V (colar, a viagem é criada na posição actual do rato)
· Criar Viagens
Seleccionar opção do menu Inserir


Horario de Servicos de Viaturas

Horário de Serviços de Viaturas
O Horário de Serviços de Viaturas está colocado na parte central da área de trabalho da aplicação.

Contempla o desenho dos blocos de trabalho, que são posicionadas nos eixos horário (horizontal), e de serviços de viatura (vertical).

Um serviços de viatura é composto por zero ou mais blocos de trabalho.

Os blocos de trabalho têm sempre visível, quando definido, os nós de início e de fim.

Um bloco de trabalho pode estar em zero ou mais serviço de motorista No primeiro caso, a cor do bloco de trabalho é transparente, no segundo caso a cor é a desse(s) serviço(s) e é apresentado o nome dos serviços.

Os nomes são ocultados quando o utilizador faz passar o rato sobre o bloco de trabalho, para facilitar a visualização do interior.

Dentro do bloco de trabalho podem existir viagens, que irão ser apresentadas de forma representativa.

Se houver um serviço de motorista que tenha blocos de trabalho em diferentes serviços de viatura, são criadas linhas que ligam esses blocos nos serviços de viaturas com a cor do serviço de motorista.


Horario de Servicos de Tripulante

Horário de Serviços de Tripulante
O Horário de Serviços de Tripulantes está colocado na parte superior da área de trabalho da aplicação.

Contempla o desenho dos blocos de trabalho, que são posicionadas nos eixos horário (horizontal), e de serviços de tripulante (vertical).

Um serviços de tripulante é composto por zero ou mais blocos de trabalho.

Os blocos de trabalho têm sempre visível, quando definido, os nós de início e de fim.

Um bloco de trabalho pode estar em zero ou mais serviço de tripulante No primeiro caso, a cor do bloco de trabalho é transparente, no segundo caso a cor é a desse(s) serviço(s) e é apresentado o nome dos serviços.

Os nomes são ocultados quando o utilizador faz passar o rato sobre o bloco de trabalho, para facilitar a visualização do interior.

Dentro do bloco de trabalho podem existir viagens, que irão ser apresentadas de forma representativa.

Se houver um serviço de tripulante que tenha blocos de trabalho em diferentes serviços de viatura, são criadas linhas que ligam esses blocos nos serviços de tripulantes com a cor do serviço de viatura.


Janela de Filtro

A Janela de Filtro é constituída por:

Separador Simples:

Neste separador podemos criar filtros simples.
É listado as características do tipo de dados a filtrar e por cada característica definida é construída uma condição.

Duas ou mais característica definidas implica a intersecção das condições definidas.

Separador Composto:

Neste separador podemos criar filtros composto.

· Opções de Campo, Condição e Valor

Campo permite definir uma característica do tipo de dados associado, para a qual queremos criar uma condição.

Condição permite definir o tipo de condição .

Valor permite definir o valor da condição. Existem dois tipos de Valor que são Valor ou Campo.
Quando definimos o valor como sendo do tipo Valor, estamos atribuir ao campo um dado concreto.
Quando definimos o valor como sendo do tipo Campo, estamos atribuir à condição um valor que é uma característica do tipo de dados associado.

Exemplo:
Se eu tiver um tipo de dados que tem como características Hora de Início e Hora de Fim e definir o Campo como sendo Hora de Início e definir a Condição como sendo Igual (=).

Uma definição do tipo Valor: "Hora de Início" "Igual(=)" " 12:10".
Uma definição do tipo Campo: "Hora de Início" "Igual(=)" "Hora de Fim".

Ao definir estas 3 opções fica definida uma condição.

· Raiz do Filtro

A Raiz do Filtro permite ver a árvore com todas condições/(sub-)filtros que foram definidos.

Sobre o filtro, podemos efectuar as seguintes operações:

Adicionar permite adicionar ao filtro previamente seleccionado a condição previamente definida.

Sub-Filtro permite adicionar um sub-filtro a um filtro previamente seleccionado.

Remover permite eliminar um sub-filtro ou condição previamente seleccionada.

Para Cima permite mover para cima um filtro ou uma condição previamente seleccionada.

Para Baixo permite mover para baixo um filtro ou uma condição previamente seleccionada.

· Operadores lógicos

Permite definir qual o operador lógico aplicar a uma condição ou a um filtro previamente seleccionado.

Na parte inferior da janela estão disponíveis as seguintes funcionalidades:

Limpar permite limpar as condições criadas.

Ver permite ver na janela de lista apenas os elementos que satisfazem a(s) condição(ões) definida(s).

Nota: Neste caso, os elementos que não satisfazem a(s) condição(ões) definida(s) serão ocultados.

Seleccionar permite seleccionar na janela de lista os elementos que satisfazem a(s) condição(ões) definida(s).

Fechar permite fechar a janela de filtro.


Janela de Lista
A Janela de Lista é uma janela que permite listar elementos do mesmo tipo de dados e permite efectuar as seguintes operações, sobre os elementos da lista:

· Criar um elemento novo;
· Editar um elemento previamente seleccionado;
· Apagar um ou mais elementos previamente seleccionados;

Para além destas operações principais, temos:

· Usado por que permite listar todos os elementos que usam o elemento previamente seleccionado.

· Filtrar os dados apresentados na lista de acordo com uma ou mais condições.

· Fechar permite fechar a janela de lista.

· Ver que permite seleccionar os elementos que se pretendem visualizar (canto inferior esquerdo)
· Ver Todos os elementos
· Ver Elementos que podem ser eliminados

Nota:
1. O duplo clique sobre um elemento da lista permite abrir a janela de edição do elemento seleccionado.

2. Na parte inferior da janela é mostrado a informação sobre o número de elementos seleccionados e o número total de elementos na lista.

3. Alguns tipos de dados exigem funcionalidades adicionais, que serão descritas sempre que necessário.

Passos a efectuar:

Criar um elemento:

1. Clicar no botão Criar

Editar um elemento:

1. Seleccionar na lista de elementos, o elemento que se pretende editar
2. Clicar no botão Editar

Apagar um ou mais elementos:

1. Seleccionar na lista de elementos, um ou mais elemento que se pretende editar
2. Clicar no botão Apagar

Usado Por:
1. Seleccionar na lista de elementos, o elemento que se pretende.
2. Clicar no botão Usado Por.


Janela Usado Por
A Janela Usado Por é uma janela que permite listar todos os elementos que usam o elemento previamente seleccionado.

Esta janela pode apresentar um ou mais listas de elementos, dependendo do número de tipos de dados diferentes que podem usar o elemento previamente seleccionado.

Nota: Em qualquer lista de elementos apresentada na janela é possível fazer duplo clique sobre um elemento, para ver mais informações. Todas as informações são exibidas em modo de leitura.


Janela de Opcões

Janela de Opções
A Janela de Opções é uma janela que permite definir definições base da aplicação, assim como obter informações e actualizações da aplicação.

A Janela de Opções é constituída por:

Separador Geral:

· Definições da Interface
· Outras Definições

Separador Resources:

· Obter actualizações
· Contacte-nos
· Ir para o OPT GISTLight Online
· Acerca OPT GISTLight


Controlo

O controlo gráfico de Mapa permite a visualização georreferenciada dos nós, percursos e linhas num mapa.

O controlo dá a possibilidade de visualizar essa informação colocada sobre um de dois fundos: ficheiros shapefiles ou em OpenStreetMap. O primeiro, tem um conjunto de ficheiros já enviados com a aplicação, mas o utilizador pode adicionar outros ficheiros a que tenha acesso. No segundo caso, requer uma ligação à internet para fazer download das imagens.

Pode configurar a opção de preferência na janela de opções.

No separador de mapa estão também disponíveis as opções relativas ao controlo do mapa.

As opções disponíveis são:

· Mais / Menos
Aumenta ou diminui o nível de Zoom do mapa. Em alternativa pode ser usada a roda do rato

· Centrar
Centra o mapa à informação da rede disponível.

· Ver Linhas
Coloca o mapa em modo de visualização de Linhas.

· Ver Rede
Coloca o mapa em mode de visualização de Rede (com percursos).

· Criar Percursos
Permite criar percursos no mapa. Ao clicar na opção abre uma janela por baixo, onde irão constar os nós que podem ser selecccionados directamente no mapa. Para remover um nó da lista, fazer duplo clique sobre esse item na lista. Quando terminar a definição do percurso clicar no botão [image] para aceitar ou em [image] para cancelar.

· Mapa Visível

Se estiver seleccionado, o mapa (de fundo) está visível, caso contrário, o mapa é ocultado.

· Tamanhos dos elementos

Permite ajustar o tamanho dos nós e das linhas para auxiliar na visualização da rede, especial-mente útil para redes cuja a distância entre os nós seja grande, o que resulta num nível de zoom bastante afastado quando se pretende visualizar todo a rede (como através do botão centrar).

Todas as outras operações sobre o mapa são feitas através do uso do rato.

O botão esquerdo do rato é usado para navegar no mapa quando se prime e se movimenta o rato ou, usando fazendo apenas um clique, para se seleccionar um objecto. (Nota: se houver vários objectos sobrepostos todos serão seleccionados).

O botão direito do rato abre o menu de contexto do mapa que permite as seguintes operações:

· Criar nós

· Mover Nós (quando um nó está seleccionado)

· Visualizar nome / Ver / Editar Nó (quando se clica sobre um nó)

· Visualizar nome / Ver / Editar Percurso (quando se clica sobre um segmento)

A roda do rato é usada para aumentar ou diminuir o nível de zoom do mapa.

O botão do meio do rato (pressionar sem largar a roda do rato) é possível criar uma caixa de selecção de vários objectos. Para criar várias caixas deve-se usar a tecla CTRL + pressionar a roda do rato.

Se o utilizador criou nós fora deste controlo, pode posicionar o nó no mapa através de um clique com o botão direito do rato, na posição pretendida, e com recurso à opção "Localizar o nó <nome_do_nó> aqui".


Nos

Nós
Um Nó é um ponto da rede de transportes com importância para o processo de planeamento. Exemplos de nós são estações de recolha e paragens ao público, embora nem todos os pontos pertencentes a estas categorias (em especial, as paragens) dêem origem a nós.

O Nó é constituído pelas seguintes propriedades:

· Nome
· Abreviatura
· Latitude
· Longitude
· Tempo máximo de paragem (viaturas)
· Capacidade de viaturas
· Pontos de Informação

E pode ser definido como sendo:
· Estação de Recolha
· Ponto de Rendição

Na janela de lista de Nós é apresentado a lista de nós da rede.

Na janela de criação e na janela de edição do Nó é permitido (re)definir as propriedades do nó.

Passos a efectuar para criar ou editar um nó:

1. Preencher a propriedade Nome:

É permitido inserir até 40 caracteres alfanuméricos.
Esta propriedade é de preenchimento obrigatório.

2. Preencher a propriedade Abreviatura:

É permitido inserir até 10 caracteres alfanuméricos.
Esta propriedade é de preenchimento obrigatório.

3. Preencher a propriedade Latitude:

É permitido inserir valores numéricos e valores negativos.
Esta propriedade não é de preenchimento obrigatório.

Exemplos:
48,478888977 ou - 48,478888977

4. Preencher a propriedade Longitude:

É permitido inserir valores numéricos e valores negativos.
Esta propriedade não é de preenchimento obrigatório.

Exemplos:
48,478888977 ou - 48,478888977

5. Preencher a propriedade Tempo máximo de paragem:

É permitido inserir valores numéricos positivos.
Esta propriedade não é de preenchimento obrigatório e refere-se ao tempo máximo de paragem de uma viatura no nó.

Exemplo: 00:15

6. Preencher a propriedade Capacidade:

É permitido inserir valores numéricos positivos.
Esta propriedade não é de preenchimento obrigatório e refere-se ao número máximo de viaturas (total, ou seja, de todos os tipo) que podem estar paradas nó.
Nota: utilizado no algoritmo de geração automática de serviços de viatura.

Exemplo: 10
7. Definir a propriedade Estação de Recolha:
Deve seleccionar o campo Estação de Recolha para definir o nó como sendo uma Estação de Recolha, caso contrário deve desseleccionar o campo.

8. Definir a propriedade Ponto de Rendição:

Deve seleccionar o campo Estação de Recolha para definir o nó como sendo uma Estação de Recolha, caso contrário deve desseleccionar o campo.

9. Definir os Pontos de Informação .

10. Para guardar o novo / guardar as alterações do nó deve clicar em Ok e para cancelar a criação/edição do nó deve clicar em Cancelar.


Pontos de Informacao

Pontos de Informação
Um Ponto de Informação é um aspecto relevante num determinado nó para uma determinada hora.

O Ponto de Informação é constituído pelas seguintes propriedades:

· Tempo
· Descrição

Na janela de criação do nó e na janela de edição do nó é possível definir uma lista de pontos de informação para o nó em causa.

As operações disponíveis são:
· Inserir um novo ponto de informação.
· Editar um ponto de informação previamente seleccionado.
· Eliminar um ou mais pontos de informação previamente seleccionado.

Na janela de criação e na janela de edição do Ponto de Informação é permitido (re)definir as propriedades do ponto de informação.

Passos a efectuar para criar ou editar um ponto de informação:

1. Preencher a propriedade Tempo:

É permitido inserir uma hora.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 12:15

2. Preencher a propriedade Descrição:

É permitido inserir caracteres alfanuméricos.
Esta propriedade é de preenchimento obrigatório.

3. Para guardar o novo/ guardar as alterações do ponto de informação deve clicar em Ok e para cancelar a criação/edição do ponto de informação deve clicar em Cancelar.


Tempo de Deslocacao da Tripulacao

Tempo de Deslocação da Tripulação
O Tempo de Deslocação da Tripulante consiste no tempo que um tripulante demora necessita para se deslocar de um ponto de rendição para o outro.

O Tempo de Deslocação da Tripulante é constituído pelas seguintes propriedades:

· Nó

· Duração

Na janela de Tempos de Deslocação da Tripulação é apresentado:

· Lista de Nós com todos os nós da rede

· Lista de Tempos de Deslocação da Tripulante com todos os tempos de deslocação para o nó seleccionado na lista de nós.

· Filtro permite filtrar a informação da lista de nós de forma a encontrar rapidamente o nó pretendido

· Filtrar por Nó de Fim permite filtrar a informação na lista de tempos de deslocação de forma a encontrar rapidamente o tempo de deslocação, pelo seu nó de fim.

· Filtrar por Linha permite filtrar os nós e os tempos de deslocação de uma determinada linha.

Passos a efectuar para definir tempos de deslocação:

1. Seleccionar um nó na lista de nós.
2. Seleccionar o tempo de deslocação na lista de tempos de deslocação
3. Definir a duração do tempo de deslocação.
Exemplo: "00:15"


Percursos

Percurso
Um Percurso é um trajecto entre dois nós .

O Percurso é constituído pelos Nós do Percurso, e pode ser definido como sendo vazio ou não.

Na janela de lista de Percursos é apresentado a lista de percursos da rede.

Esta janela apresenta funcionalidades específicas do Percurso que não estão definidas na janela de lista base. Essas funcionalidades são:

· Duplicar e Inverter permite criar uma cópia do percurso seleccionado e inverter a ordem dos nós do percurso.
· Duplicar permite criar uma cópia do percurso.
· Ver permite seleccionar os elementos que se pretendem visualizar (canto inferior esquerdo)
· Ver Percursos vazios
· Ver Percursos normais

Passos a efectuar:
Duplicar e Inverter um percurso:

1. Seleccionar na lista de elementos, o elemento que se pretende duplicar.
2. Clicar no botão Duplicar e Inverter

Duplicar um percurso:

1. Seleccionar na lista de elementos, o elemento que se pretende duplicar.
2. Clicar no botão Duplicar

Na janela de criação e na janela de edição do Percurso é permitido (re)definir as propriedades do percurso.

Nesta janela temos o grupo:

Geral onde se pode definir a propriedade

Vazio

Nós do Percursos onde se pode definir a lista de nós do percurso.

Temos disponíveis:

· Opção com todos os nós da rede
· Lista de todos os nós do percurso
· Lista de segmentos entre os vários nós do percurso

e as operações

· Inserir que permite inserir na lista de nós do percurso um nó.
· Eliminar que permite eliminar da lista de nós do percurso um nó.
· Mover para cima que permite mover para cima um nó na lista de nós do percurso.
· Mover para baixo que permite mover para baixo um nó na lista de nós do percurso.

Passos a efectuar para criar um percurso:

1. Definir a propriedade Vazio:
Deve seleccionar o campo Vazio para definir o nó como sendo Vazio, caso contrário deve desseleccionar o campo.

2. Definir os Nós do Percurso:

2.1. Seleccionar um nó na opção que contém todos os nó da rede.

2.2. Seleccionar na lista de nós a posição anterior onde se pretende inserir, caso não seja definida esta posição, o nó é inserido no final da lista.

2.3. Clicar no botão Inserir.

2.4. O nó passa a estar presente na lista de nós do percurso.

2.5. Na lista de segmentos são criados os segmentos de acordo com a lista de nós do percurso. Devem ser definidas:

2.5.1 Duração

É permitido inserir um tempo.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 00:15

2.5.2 Distância

É permitido inserir um valor numérico inteiro.

O valor pode ser expresso em qualquer unidade, recomenda-se a utilização de metros.

Esta propriedade não é de preenchimento obrigatório.

3. Para guardar o novo percurso deve clicar em Ok e para cancelar a criação deve clicar em Cancelar.

Outros passos a efectuar na criação de um percurso:

Funcionalidades que se podem realizar sobre os nós do percurso:

· Eliminar um nó do percurso:

Clicar no nó da lista de nós do percurso que se pretende eliminar.
Clicar no botão Eliminar.

· Mover para cima um nó do percurso:

Clicar no nó da lista de nós do percurso que se pretende mover.
Clicar no botão Mover para Cima
Definir a duração dos segmentos que não tenho valor definido.

· Mover para baixo um nó do percurso:

Clicar no nó da lista de nós do percurso que se pretende mover.
Clicar no botão Mover para Baixo
Definir a duração dos segmentos que não tenho valor definido.

Nota:
Na edição de um percurso não está disponível as operações Mover para cima e Mover para baixo.
Caso pretenda mover um nó sugerimos que elimine o nó em causa, adicione o nó na posição pretendida e defina a duração de todos os segmentos, caso seja necessário.


Linhas

Linha
Uma Linha corresponde a um conjunto de percursos entre dois pontos que irá dar origem a um horário ao público. Normalmente uma linha terá, pelo menos, dois percursos em sentidos opostos, e por vezes poderá ter percursos mais pequenos que permitem reforçar a oferta em algumas das áreas cobertas pela linha.

A Linha é constituída pelas seguintes propriedades:

· Nome
· Cor
· Notas
· Percursos da Linha

Na janela de lista de Linhas é apresentado a lista de linhas da rede.

Na janela de criação e na janela de edição da linha é permitido (re)definir as propriedades da linha.

Passos a efectuar para criar ou editar uma linha:

1. Preencher a propriedade Nome:

É permitido inserir até 40 caracteres alfanuméricos.
Esta propriedade é de preenchimento obrigatório.

2. Definir a propriedade Cor:
É permitido definir uma cor clicando no botão onde aparece a cor ou clicar no separador do lado direito do botão, aparecendo assim um popup com algumas cores, basta clicar na cor pretendida.

Na criação de uma nova linha, esta propriedade é preenchida com uma cor aletória.

3. Preencher a propriedade Notas:

É permitido inserir caracteres alfanuméricos.
Esta propriedade não é de preenchimento obrigatório.

4. Definir os Percursos da Linha .

5. Para guardar a nova / guardar as alterações da linha deve clicar em Ok e para cancelar a criação/edição do nó deve clicar em Cancelar.


Percursos da Linha
Um Percurso da Linha é um percurso que pertence a uma determinada linha e para essa linha tem uma determinada orientação.

Um Percurso da Linha é constituído pelas seguintes propriedades:
· Percurso
· Orientação

O Nome do Percurso é construído com base nos nós que o compõem separados pelo símbolo '>'

O separador percursos da linha disponibiliza do lado esquerdo uma lista com os elementos dis-poníveis, ou seja, de entre os percursos do horário os que ainda não estejam seleccionados, que são apresentados na lista do lado direito.

Os botões ao centro permitem manipular os elementos que estão seleccionados.

Em baixo existe um filtro que auxilia não apresentação dos elementos disponíveis de acordo com um conjunto de características do percurso (normal, vazio, sem associação e todos).

O utilizador pode seleccionar todos os percursos que desejar para a linha.


Tipos de Viatura
Um Tipo de Viatura agrupa conjuntos de viaturas com as mesmas características. Exemplos de diferentes tipos de viatura são eléctricos, autocarros articulados ou autocarros com tracção às quatro rodas.

O Tipo de Viatura é constituído pelas seguintes propriedades:

· Nome
· Autonomia
· Custo

Na janela de lista de Tipos de Viatura é apresentado a lista de tipos de viatura da rede.

Na janela de criação e na janela de edição de tipos de viatura é permitido (re)definir as propriedades do tipo de viatura.

Passos a efectuar na criação ou edição do tipo de viatura:

1. Preencher a propriedade Nome:

É permitido inserir até 40 caracteres alfanuméricos.

Esta propriedade é de preenchimento obrigatório.

2. Preencher a propriedade Autonomia:

É permitido inserir um valor numérico inteiro.

Esta propriedade é de preenchimento obrigatório.

A Autonomia é expressa em kms. Este valor é considerado na validação dos serviços de viatura, caso também seja preenchido a propriedade Distância dentro dos percursos.

Exemplo: 500

3. Preencher a propriedade Custo:

É permitido inserir um valor numérico inteiro.

Esta propriedade é de preenchimento obrigatório.

Este valor deverá ser preenchido de forma relativa aos restantes tipos de viaturas.

Exemplo: Viatura Normal - 1000; Viatura Articulada - 1500;


Viagens
Uma Viagem é a definição de horário do percurso.

Uma Viagem é constituída pelas seguintes propriedades:

· Linha
· Percurso
· Orientação
· Notas
· Tipos de Viatura
· Horas de Passagem

E pode ser definida como sendo:

· Vazia

Na janela de lista de Viagens é apresentado a lista de Viagens do horário.

Na janela de criação e na janela de edição da Viagem é permitido (re)definir as propriedades da viagem.

Passos a efectuar para criar ou editar uma viagem:

1. Definir a propriedade Linha:

Na opção de linha, aparece todas as linhas da rede, seleccione a que pretende.

Esta propriedade não é de preenchimento obrigatório.

Nota: Esta propriedade quando não é definida, significa que estamos perante uma viagem em vazio.

2. Definir a propriedade Percurso:

Na opção de percurso, aparece todos os percursos da rede, seleccione o que pretende.

Esta propriedade é de preenchimento obrigatório.

3. Definir a propriedade Vazia:

Esta propriedade não é de preenchimento obrigatório.

Por omissão é definida como não sendo Vazia.

4. Definir a propriedade Orientação:

Na opção de orientação é possível escolher uma das 4 orientações disponíveis:
Indeterminado
Ida
Volta
Circular

Nota: Por omissão é definido como Indeterminado. O correcto preenchimento é importante para a geração de relatórios.

5. Preencher a propriedade Notas:

É permitido inserir caracteres alfanuméricos.

Esta propriedade não é de preenchimento obrigatório.

6. Definir a propriedade Tipos de Viatura :

Esta propriedade não é de preenchimento obrigatório.

7. Definir a propriedade Horas de Passagem :

Esta propriedade é de preenchimento obrigatório.

8. Para guardar a nova / guardar as alterações da viagem deve clicar em Ok e para cancelar a criação/edição da viagem deve clicar em Cancelar.

Nota:
Para saber sobre o separador de Informação, consulte: Informações


Tipos de Viatura
O separador de Tipos de Viaturas na janela de criação e na janela de edição da viagem permite definir quais os tipos de viaturas permitidos ou os tipos de viaturas não permitidos pela viagem .

Tipos de Viatura é constituído por:

· Lista de tipos de viatura disponíveis
· Lista de tipos de viatura permitidos
· Lista de tipos de viatura não permitidos

e para cada lista de tipos de viatura permitidos e lista de tipos de viatura não permitidos é disponibilizados as operações:

· Seleccionar
· Desseleccionar

Passos a efectuar para definir a lista de tipos de viatura permitidos:

Para Seleccionar um tipo de viatura permitido:

1. Seleccionar um tipo de viatura na lista de tipos de viatura disponíveis
2. Clicar no botão seleccionar que se situa entre a lista de tipos de viatura disponíveis e tipos de viatura permitidos

Para Desseleccionar um tipo de viatura permitido:

1. Seleccionar o tipo de viatura na lista de tipos de viatura permitidos que se pretende retirar.
2. Clicar no botão desseleccionar que se situa entre a lista de tipos de viatura disponíveis e tipos de viatura permitidos.

Passos a efectuar para definir a lista de tipos de viatura não permitidos:

Para Seleccionar um tipo de viatura não permitido:

1. Seleccionar um tipo de viatura na lista de tipos de viatura disponíveis.
2. Clicar no botão seleccionar que se situa entre a lista de tipos de viatura disponíveis e tipos de viatura não permitidos.

Para Desseleccionar um tipo de viatura não permitido:

1. Seleccionar o tipo de viatura na lista de tipos de viatura não permitidos que se pretende retirar.
2. Clicar no botão desseleccionar que se situa entre a lista de tipos de viatura disponíveis e tipos de viatura não permitidos.

Nota: Apenas se pode definir a lista de tipos de viatura permitidos ou tipos de viatura não permitidos.


Horas de Passagem
Um Hora de Passagem indica a hora em que uma viagem deve passar num determinado nó .

Uma Hora de Passagem é constituída pelas seguintes propriedades:

· Nó
· Hora

E pode ser definido como sendo:

· Usada
· Ponto de rendição

O separador de Horas de Passagem na janela de criação e na janela de edição da viagem permite definir qual a hora que uma viagem deve passar em cada nó do percurso da viagem.

Horas de Passagem é constituído por:

· Lista de horas de passagem

e a operação de :

· Calcular Horas de Passagem permite calcular automaticamente as horas de passagem com base na duração média dos nós do percurso. O utilizador pode preencher quaisquer horas da lista de horas de passagem.

Passos a efectuar para definir as horas de passagem:

Requisito: O percurso da viagem deve estar definido

1. Para cada hora de passagem na lista, deve definir a hora.
2. Seleccionar a opção Usada

Nota: As horas de passagem que não vão ser usadas devem ter a opção Usada desseleccionada.

Passos para alterar a ordem dos nós das Horas de Passagem.

O nó da hora de passagem é definido de acordo com os nós do percurso e não é possível alterar directamente o nó, nem é possível alterar directamente a ordem da hora de passagem.

Para alterar a ordem deve:

1. Definir qual o nó que se pretende alterar.
2. Reconhecer o Percurso associado.
3. Alterar a ordem dos nós do percurso

Caso seja possível alterar o percurso associado, deve-se modificar a ordem dos nó do percurso de acordo com a ordem pretendida.

Caso não seja possível alterar o percurso, deve ser feito uma cópia do percurso.
Na lista de nós do percurso deve ser alterada a ordem dos nós do percurso de acordo com o pretendido.
Na viagem em causa, deve ser seleccionado este percurso alterado.
Deve ser definida as horas de passagem que estivem por definir.


Informacões

Informações
O separador de Informação na janela de criação e na janela de edição de uma viagem disponibiliza a informação sobre os serviços associados á viagem em causa.

Informação é constituído pelos grupos:

· Serviços de Motorista lista todos os serviços de motorista associados á viagem em causa.
· Serviços de Viatura lista todos os serviços de viatura associados á viagem em causa.

Nota: Esta tab só é visível quando se está a editar a viagem.


Servicos de Viatura

Serviços de Viatura
Um Serviço de Viatura corresponde ao trabalho a realizar ou realizado por uma viatura. Este serviço pode corresponder a um turno do horário de viaturas ou a um serviço do horário de serviços

Um Serviço de Viatura é constituído pelas seguintes propriedades:

· Nome
· Cor
· Notas
· Blocos de Trabalho
· Viagens
· Valores dos parâmetros

Na janela de lista de Serviços de Viatura é apresentado a lista de Serviços de Viatura do horário.

Na janela de criação e na janela de edição do Serviço de Viatura é permitido (re)definir as propriedades do Serviço de Viatura.

Passos a efectuar para criar ou editar um serviço de viatura:

1. Definir a propriedade Nome:

É permitido inserir até 40 caracteres alfanuméricos.

Esta propriedade é de preenchimento obrigatório.

2. Definir a propriedade Cor:

É permitido definir uma cor clicando no botão onde aparece a cor ou clicar no separador do lado direito do botão, aparecendo assim um popup com algumas cores, basta clicar na cor pretendida.

3. Definir a propriedade Notas:

É permitido inserir caracteres alfanuméricos.
Esta propriedade não é de preenchimento obrigatório.

4. Definir a propriedade Blocos de Trabalho :

5. Definir a propriedade Viagens :

6. Preencher os Valores dos parâmetros que queira incluir no tipo.

Os valores do parâmetros dependem dos parâmetros que estejam definidos na parametrização dinâmica de serviços .

7. Para guardar o novo / alterações do serviço de viatura deve clicar em Ok e para cancelar a criação/edição do serviço de viatura deve clicar em Cancelar.


Blocos de Trabalho
No separador Blocos de Trabalho é permitido definir os blocos de trabalho do serviço de viatura e definir quais os serviços de tripulante associados a cada bloco de trabalho.

Blocos de Trabalho é constituído por:

Grupo de blocos de trabalho que é constituído por

· Lista de todos os blocos de trabalho

e as operações

· Inserir
· Editar
· Eliminar
· Quebrar
· Juntar

Grupo de Serviços de Tripulante

· Lista de Elementos disponíveis
· Lista de Elementos seleccionados

Passos a efectuar para Inserir um bloco de trabalho:

1. Clicar no botão Inserir
2. Definir o bloco de trabalho

Passos a efectuar para Editar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Editar
3. Editar o bloco de trabalho

Passos a efectuar para Apagar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Apagar

Passos a efectuar para Quebrar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Quebrar
3. Na janela Quebrar Bloco de Trabalho, é apresentado os pontos de rendição disponíveis. Seleccione um ponto de rendição.
4. Para confirmar a operação Ok e para cancelar a operação clique em Cancelar.

Passos a efectuar para Juntar um bloco de trabalho:

1. Seleccionar dois blocos de trabalho na lista de blocos de trabalho
2. Clicar no botão Juntar

Passos a efectuar para criar os blocos de trabalho do serviço e os respectivos serviços de tripulante:

1. No grupo de blocos de trabalho deve criar os blocos de trabalho do serviço de viatura.

2. Definir os serviços de um bloco de trabalho:

2.1. Deve seleccionar no bloco de trabalho para o qual pretende definir os serviços de tripulante.

2.2. No grupo de Serviços de Tripulante, aparece a lista de serviços disponíveis, deve seleccionar o serviço que pretende.

2.3. Clicar no botão Associar.
Nota: É possível efectuar alterações sobre os serviços de motorista, em seguida será apresentado os passos para efectuar as operações de associar e desassociar serviços, para o bloco de trabalho seleccionado.

Passos para associar serviços de tripulante:

1. Seleccione um serviço na lista de elementos disponíveis
2. Clique no botão Associar

Passos para desassociar serviços de tripulante:

1. Seleccione um serviço na lista de elementos seleccionados
2. Clique no botão Desassociar


Viagens
O separador de Viagens na janela de criação e na janela de edição do Serviço de Motorista permite definir as viagens que são feitas pelo serviço de motorista em causa.

Viagens é constituído por:

· Lista de viagens disponíveis
· Lista de viagens seleccionadas

e as operações:

· Seleccionar
· Desseleccionar

Passos a efectuar para:

Seleccionar uma viagem:

1. Seleccionar um tipo de viatura na lista de viagens disponíveis

2. Clicar no botão seleccionar

Desseleccionar uma viagem:

1. Seleccionar um tipo de viatura na lista de viagens seleccionadas.

2. Clicar no botão desseleccionar.

Nota: estas operação de selecção e desselecção têm como resultado alterações aos blocos de trabalho que compõem o serviço.


Blocos de Trabalho

BCSV
Um Bloco de Trabalho é um conjunto de viagens feitas, sem interrupções, por uma mesma viatura.

Um Bloco de Trabalho é constituído pelas seguintes propriedades:

· Hora de Início
· Hora de Fim
· Nó de Início
· Nó de Fim
· Notas

Passos a efectuar para criar ou editar um bloco de trabalho:

1. Definir a propriedade Hora de Início

É permitido inserir um tempo.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 00:15

2. Definir a propriedade Hora de Fim

É permitido inserir um tempo.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 12:15

3. Definir a propriedade Nó de Início

Seleccionar um nó na opção, que contém todos os nó da rede.

Esta propriedade não é de preenchimento obrigatório.

4. Definir a propriedade Nó de Fim

Seleccionar um nó na opção, que contém todos os nó da rede.
Esta propriedade não é de preenchimento obrigatório.

5. Definir a propriedade Notas

É permitido inserir caracteres alfanuméricos.

Esta propriedade não é de preenchimento obrigatório

6. Para guardar o novo / as alterações do bloco de trabalho deve clicar em Ok e para cancelar a criação/edição do bloco de trabalho deve clicar em Cancelar.

Passos a efectuar para quebrar um bloco de trabalho:

1. Seleccionar o ponto de rendição onde se vai quebrar o bloco de trabalho.

2. Para confirmar esta operação clique em Ok e para cancelar esta operação clique Cancelar.


Servicos de Tripulante

Serviços de Tripulante
Um Serviço de Tripulante corresponde ao período diário de uma tripulação. Um serviço é definido como uma sequência de blocos de trabalho obedecendo a um conjunto de regras.

Um Serviço de Tripulante é constituído pelas seguintes propriedades:

· Nome
· Cor
· Tipo de Serviço de Tripulante
· Notas
· Blocos de Trabalho
· Viagens
· Valores dos parâmetros

Na janela de lista do Serviço de Tripulante é apresentado a lista do Serviço de Tripulante do horário.

Na janela de criação e na janela de edição do Serviço de Tripulante é permitido (re)definir as propriedades do serviço de tripulante.

Passos a efectuar para criar ou editar um Serviço de Tripulante:

1. Definir a propriedade Nome:

É permitido inserir até 40 caracteres alfanuméricos.

Esta propriedade é de preenchimento obrigatório.

2. Definir a propriedade Cor:

É permitido definir uma cor clicando no botão onde aparece a cor ou clicar no separador do lado direito do botão, aparecendo assim um popup com algumas cores, basta clicar na cor pretendida.

3. Definir a propriedade Tipo de Serviço de Tripulante:

Na opção Tipo de Serviço de Tripulante são apresentado todos os tipos de Serviço de Tripulante definidos no horário, deve ser seleccionado um tipo.

Esta propriedade é de preenchimento obrigatório.

4. Definir a propriedade Notas:

É permitido inserir caracteres alfanuméricos.
Esta propriedade não é de preenchimento obrigatório.

5. Definir a propriedade Blocos de Trabalho :

6. Definir a propriedade Viagens :

7. Preencher os Valores dos parâmetros que queira incluir no tipo.

Os valores do parâmetros dependem dos parâmetros que estejam definidos na parametrização dinâmica de serviços .

8. Para guardar o novo / alterações do serviço de tripulante deve clicar em Ok e para cancelar a criação/edição do serviço de tripulante deve clicar em Cancelar.


Blocos de Trabalho
No separador Blocos de Trabalho é permitido definir os blocos de trabalho do serviço de tripulante e definir quais os serviços de viatura associados a cada bloco de trabalho.

Blocos de Trabalho é constituído por:

Grupo de blocos de trabalho que é constituído por

· Lista de todos os blocos de trabalho

e as operações

· Inserir
· Editar
· Eliminar
· Quebrar
· Juntar

Grupo de Serviços de Viatura

· Lista de Elementos disponíveis
· Lista de Elementos seleccionados

Passos a efectuar para Inserir um bloco de trabalho:

1. Clicar no botão Inserir
2. Definir o bloco de trabalho

Passos a efectuar para Editar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Editar
3. Editar o bloco de trabalho

Passos a efectuar para Apagar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Apagar

Passos a efectuar para Quebrar um bloco de trabalho:

1. Seleccionar um bloco de trabalho na lista de blocos de trabalho
2. Clicar no botão Quebrar
3. Na janela Quebrar Bloco de Trabalho, é apresentado os pontos de rendição disponíveis. Seleccione um ponto de rendição.
4. Para confirmar a operação Ok e para cancelar a operação clique em Cancelar.

Passos a efectuar para Juntar um bloco de trabalho:

1. Seleccionar dois blocos de trabalho na lista de blocos de trabalho
2. Clicar no botão Juntar

Passos a efectuar para criar os blocos de trabalho do serviço e os respectivos serviços de viatura:

1. No grupo de blocos de trabalho deve criar os blocos de trabalho do serviço de Tripulante.

2. Definir os serviços de um bloco de trabalho:

2.1. Deve seleccionar no bloco de trabalho para o qual pretende definir os serviços de viatura.

2.2. No grupo de Serviços de Viatura, aparece a lista de serviços disponíveis, deve seleccionar o serviço que pretende.

2.3. Clicar no botão Associar.
Nota: É possível efectuar alterações sobre os serviços de viatura, em seguida será apresentado os passos para efectuar as operações de associar e desassociar serviços, para o bloco de trabalho seleccionado.

Passos para associar serviços de viatura:

1. Seleccione um serviço na lista de elementos disponíveis
2. Clique no botão Associar

Passos para desassociar serviços de viatura:

1. Seleccione um serviço na lista de elementos seleccionados
2. Clique no botão Desassociar


Viagens
O separador de Viagens na janela de criação e na janela de edição do Serviço de Tripulante permite definir as viagens que são feitas pelo serviço de viaturas em causa.

Viagens é constituído por:

· Lista de viagens disponíveis
· Lista de viagens seleccionadas

e as operações:

· Seleccionar
· Desseleccionar

Passos a efectuar para:

Seleccionar uma viagem:

1. Seleccionar um tipo de viatura na lista de viagens disponíveis

2. Clicar no botão seleccionar

Desseleccionar uma viagem:

1. Seleccionar um tipo de viatura na lista de viagens seleccionadas.

2. Clicar no botão desseleccionar.

Nota: estas operação de selecção e desselecção têm como resultado alterações aos blocos de trabalho que compõem o serviço.


Tipos de Servico de Tripulante

Tipos de Serviço de Tripulante
Um Tipo de Serviço classifica um serviço em função de um conjunto de regras a que esse serviço deve obedecer.

O Tipo de Serviço é constituído pelas seguintes propriedades:

· Nome
· Valores de parâmetros

Na janela de lista de Tipos de Serviço é apresentado a lista de tipos de serviço do documento.

Na janela de criação e na janela de edição do Tipo de Serviço é permitido (re)definir as propriedades do tipo de serviço.

Passos a efectuar:

1. Preencher a propriedade Nome

2. Preencher os Valores dos parâmetros que queira incluir no tipo.

Os valores do parâmetros dependem dos parâmetros que estejam definidos na parametrização dinâmica de serviços .


Blocos de Trabalho
Um Bloco de Trabalho é um conjunto de viagens feitas, sem interrupções, pelo mesmo tripulante.

Um Bloco de Trabalho é constituído pelas seguintes propriedades:

· Hora de Início
· Hora de Fim
· Nó de Início
· Nó de Fim
· Notas

Passos a efectuar para criar ou editar um bloco de trabalho:

1. Definir a propriedade Hora de Início

É permitido inserir um tempo.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 00:15

2. Definir a propriedade Hora de Fim

É permitido inserir um tempo.

Esta propriedade é de preenchimento obrigatório.

Exemplo: 12:15

3. Definir a propriedade Nó de Início

Seleccionar um nó na opção, que contém todos os nó da rede.

Esta propriedade não é de preenchimento obrigatório.

4. Definir a propriedade Nó de Fim

Seleccionar um nó na opção, que contém todos os nó da rede.
Esta propriedade não é de preenchimento obrigatório.

5. Definir a propriedade Notas

É permitido inserir caracteres alfanuméricos.

Esta propriedade não é de preenchimento obrigatório

6. Para guardar o novo / as alterações do bloco de trabalho deve clicar em Ok e para cancelar a criação/edição do bloco de trabalho deve clicar em Cancelar.

Passos a efectuar para quebrar um bloco de trabalho:

1. Seleccionar o ponto de rendição onde se vai quebrar o bloco de trabalho.

2. Para confirmar esta operação clique em Ok e para cancelar esta operação clique Cancelar.


Parametros Dinamicos

Parâmetros Dinâmicos
A parametrização dinâmica de serviços é um processo de criação de atributos e regras associadas aos serviços. Tem como estabelecido os seguintes objectivos:

? Possibilidade de serem definidos novos atributos/ propriedades para os serviços de pessoal tripulante. Estas propriedades podem ser genéricas (partilhadas por todos os serviços), por tipo de serviço ou por serviço, e poderão corresponder a durações, horas limite, valores numéricos, ou campos de natureza mais indicativa.

? Criação de regras de cálculo, que permitam calcular novos atributos (atributos de cálculo) a partir dos atributos definidos na alínea anterior. Para este efeito deverá ser utilizada uma linguagem de cálculo.

? Criação de novas regras de verificação, que permitam impor condições para a variação dos atributos directos ou calculados dos serviços

Quando a aplicação inicia, ou quando o utilizador abre um ficheiro novo, são criados um conjunto de parâmetros base, que estabelecem algumas regras base ao horário.

Um parâmetro é sempre constituído pelas seguintes propriedades:

· Âmbito: pode ser de cinco tipos - Serviço de Tripulante; Tipo de Serviço de Tripulante; Global; Serviço de Viatura; e Tipo de Viatura

· Nome: o que identificada o parâmetro

· Título: um texto que traduz a propriedade nome para algo mais legível pelo utilizador

· Descrição: uma descrição (mais extensa) da função do parâmetro

· Tipo: pode ser de cinco tipos - Valor; Cálculo; Validação; Tamanho de Vector; e Lista de Valores

· Nota

Relações

Âmbitos e Tipos

Os parâmetros de âmbito Serviço de Tripulante, têm como possíveis tipos: Valor, Cálculo, Validação, Tamanho de Vector, e Lista de Valores.

Os parâmetros de âmbito Tipo de Serviço de Tripulante, têm como possíveis tipos: Valor, Tamanho de Vector, e Lista de Valores.

Os parâmetros de âmbito Global, têm como tipo possível: Valor, Tamanho de Vector, Lista de Valores. Este âmbito tem como propriedade extra o grupo, que permite distinguir entre parâmetros globais de serviços de motorista e os de serviços de viatura.

Os parâmetros de âmbito Serviço de Viatura, têm como possíveis tipos: Valor, Cálculo,

Validação, Tamanho de Vector, e Lista de Valores.

Os parâmetros de âmbito Tipo de Viatura, têm como possíveis tipos: Valor, Cálculo, Validação, Tamanho de Vector, e Lista de Valores.

Tipo

Valor

Surge o separador Valor. Dentro do separador podem ser definidas as seguintes propriedades:

· Vector

O Vector pode ser definido por:

- Um valor que é introduzido noutro parâmetro (do tipo Tamanho de Vector). A esse valor pode ser adicionado um valor Δ (delta), que pode ser positivo ou negativo (e.g. Nº Pausas = Nº Etapas - 1);

- Uma dimensão fixa.

· É Tempo

Estabelece se as propriedades Valor por omissão, Mínimo e Máximo são do tipo valor normal ou do tipo tempo.

· Valor por omissão

O valor que é colocado na interface quando o valor do parâmetro é solicitado ao utilizador

· Mínimo

O valor mínimo a ser aceite pelo utilizador.

· Máximo

O valor máximo a ser aceite pelo utilizador.

Validação

Se o parâmetro for do tipo Validação surge um novo parâmetro:

· Mensagem:

Mensagem de validação/erro que o utilizador visualiza na interface gráfica.

Para visualizar os valores determinados pelo sistema, as mensagens devem conter o nome dos parâmetros dentro de chavetas (e.g. {D_Amplitude} ).

Se o parâmetro for do tipo vector e pretenda visualizar o índice em que o erro acontece deve colocar o símbolo {i}, podendo ainda ser apresentado o valor do índice seguinte {i+1} e/ou o anterior {i-1} (e.g. "(...) entre a {i} e {i+1} etapas.") .

Validação ou Cálculo

Surge o separador Procedimento, onde pode ser definida as seguintes propriedades:

· É do tipo tempo (apenas para parâmetros do tipo cálculo)

Serve essencialmente para ser exibido correctamente (no formato hh:mm) nas mensagens de validação.

· Procedimento

É um campo textual onde se deverá criar o procedimento a ser utilizado para fazer o cálculo (resultado valor decimal) ou a validação (resultado verdadeiro ou falso)

Do lado direito surge uma lista com os parâmetros que podem utilizados no procedimento.

Notas para a criação de parâmetros:

- Utilizar o nome dos parâmetros no procedimento.

- Para parâmetros do tipo vector utilizar o nome do parâmetro seguido de [i].

Lista de Valores

Surge o separador Lista de Valores

O utilizador pode adicionar nomes à lista de valores e definir qual é o elemento da lista que pretende utilizar como valor por omissão.


Parametros Globais

Parâmetros Globais


Menu de Geracao Automatica

Menu de Geração Automática
O Menu de Geração Automática é constituído por:

· Tempos de Deslocação da Tripulação
· Blocos de Trabalho
· Algoritmos de Serviços de Viaturas
· Básico

Funcionalidades do menu:

Tempos de Deslocação da Tripulação:

Permite gerar automaticamente Tempos de Deslocação para os horários de Serviços de Motorista. Utiliza como valores para a criação os definidos na janela de Tempos de Deslocação da Tripulação , e a posição definida no Tipo de Serviço de Motorista

Blocos de Trabalho:
Permite quebrar automaticamente os blocos de trabalho com base numa duração mínima.

Algoritmos de Serviço de Viatura:

· Sem tipos de viaturas
- Básico permite criar automáticamente Serviços de Viatura utilizando o algoritmo.


Basico

Básico

O algoritmo básico de viatura é um algoritmo determinístico que encontra a solução óptima para o problema de alocação de serviços viaturas a viagens. Este algoritmo não utiliza os tipos de viaturas.

Parametrização

O algoritmo é parametrizado em duas fases:

A primeira está relacionado com os Parâmetros Globais, nomeadamente os de valores de parâmetros de viatura, onde estão são definidos os seguintes parâmetros:

Nota: A aplicação atribui valores por omissão a estes parâmetros.

A segunda tem a ver com penalizações e custos, acessível nos parâmetros do algoritmo.


AntColony

O algoritmo AntColony (Colónia de Formigas) permite resolver a afectação de viagens a viaturas, considerando as restrições ao tipo de viatura e o seu custo relativo.

Permite ainda partir de soluções parciais e completar a afectação.

Parametrização

O algoritmo é parametrizado em duas fases:

A primeira está relacionado com os Parâmetros Globais, nomeadamente os de valores de parâmetros de viatura, onde estão são definidos os seguintes parâmetros:

Nota: A aplicação atribui valores por omissão a estes parâmetros.

A segunda tem a ver com penalizações e custos, acessível nos parâmetros do algoritmo.

Os parâmetros que podem ser definidos estão divididos em 4 grupos: Custos e Penalizações,

Criação de Viagens, Soluções Parciais, Opções Avançadas.

Os "Custos e Penalizações" estão relacionados com o que deve ser optimizado. O primeiro parâmetro, "Custo de um Turno", define o custo base de um serviço de viatura, que deve ter um valor suficientemente alto para não compensar usar um serviço de viatura a mais quando for possível não o fazer. Os dois parâmetros de penalização, para viagens em vazio e tempo parado num serviço de viatura, servem para penalizar o tempo gasto pelas viaturas nestas duas situações. Os dois valores vão ser multiplicados pelo tempo em segundos usado em cada um dos estados, viagem em vazio e tempo parado.

No grupo "Criar Viagens", existe apenas uma opção em que se pode definir o número de percursos em vazio que podem ser encadeados de forma a estabelecer uma ligação entre duas viagens, ou entre a estação de recolha e uma viagem.

O parâmetro "Permitir Completar Serviços Parciais" define se, caso existam serviços de viatura no momento de chamada do algoritmo, podem ser completados com outras viagens ou não.

As "Opções Avançadas" estão relacionadas com a execução do algoritmo, e na maioria dos casos devem permanecer inalterados, mas num caso com muitas viagens em que a solução possa não ser satisfatório é possível permitir ao algoritmo correr durante mais tempo na pesquisa por uma melhor solução. O primeiro parâmetro, define as iterações que passam sem uma melhoria antes de o algoritmo parar de pesquisar novas soluções e retornar a melhor encontrada. O segundo parâmetro define o número de soluções candidatas que são criadas em cada iteração.


GenT

O algoritmo GenT de tripulantes é um algoritmo que auxilia o utilizador no problema de alocação de serviços tripulante a serviços de viatura. De uma forma simples e interactiva, disponibiliza, ao utilizador, um vasto conjunto de informação sobre as soluções encontradas e permite-lhe alterar os critérios e os parâmetros dinamicamente.

Janela de Execução

A janela de execução é dividida em várias áreas:

Execução do Algoritmo:

? Nº iterações: tem como valor por omissão 100. Aconselha-se a manter o valor reduzido, dependendo da dimensão do problema as iterações irão demorar mais ou menos tempo, mas é possível durante o período de iteração parar a execução.

? Seed: o valor deste parâmetro indica a seed usada no gerador de números aleatórios utilizado no algoritmo. Os algoritmos genéticos têm uma forte componente aleatória, e cada execução do algoritmo, mesmo sem alterar os parâmetros, conduz geralmente a um conjunto de soluções diferentes. No entanto, para cada valor da seed, o resultado é sempre o mesmo. Assim, o utilizador pode obter voltar a obter uma dada solução as vezes que entender se introduzir sempre os mesmos parâmetros e a mesma seed.

Tipo de Serviços de Tripulante

Neste espaço, o utilizador pode definir quais os tipos se serviço, e os valores dos parâmetros associados, que pretende que sejam considerados na definição de uma solução.

Dados do problema

? Nº de serviços gerados: indica o número total de serviços que satisfazem todas as regras impostas para os tipos de serviços activos e para o grupo de blocos de trabalho que está a ser utilizado. Este valor dá-nos a melhor indicação sobre a dimensão real do problema, a qual afecta decisivamente a rapidez de execução do algoritmo. Todavia isto não significa que os problemas grandes forneçam necessariamente melhores soluções que os problemas mais pequenos. Para um elevado nº de serviços gerados o utilizador pode redefinir as regras dos tipos de serviços ou a divisão dos blocos de trabalho de forma a reduzir a dimensão do problema. Para uma dimensão do problema muito pequena, o utilizador poderá preferir reactivar alguns pontos de rendição ou relaxar algumas das regras dos serviços.

? Nº de blocos de trabalho inicial: representa o número de blocos de trabalho total existente no horário.

? Nº real de blocos de trabalho: indica o número de blocos de trabalho para os quais foi possível gerar serviços com as regras definidas.

? Duração total do horário: total, em horas, da duração dos blocos de trabalho iniciais.

? Duração real do horário: total, em horas, da duração dos blocos de trabalho reais.

? Duração dos bocados do problema: para alguns dos blocos de trabalho, por diversas razões, não é possível gerar serviços que os incluam. São designados por bocados do problema e representam os blocos que não serão cobertos por nenhuma solução do algoritmo. E esta duração corresponde portanto ao total, em horas, da duração dos blocos de trabalho não cobertos, ou seja, sem serviço.

Desempenho

Esta janela retorna informação sobre o desempenho do algoritmo e é actualizada dinamicamente à medida que as sucessivas iterações (definidas no espaço de execução do algoritmo) vão sendo executadas. Retorna informação sobre a iteração em curso, o seu tempo de execução correspondente e tempo restante, assim como o total de tempo já concretizado para todas as iterações realizadas.

Dados da solução

As soluções encontradas são apresentadas numa grelha, por linha, com os dados/características da solução divididas por coluna. Destas características temos:

? Nº de blocos de trabalho cobertos: conjuntos de blocos de trabalho que não estão associados a nenhum serviço. Estes blocos não cobertos referem-se apenas a blocos reais e não iniciais, ou seja, blocos de trabalho para os quais existem serviços que os poderiam cobrir.

? Nº de serviços: número de serviços efectivos da solução.

? Duração dos blocos de trabalho não cobertos: total da duração dos blocos de trabalho que, para a solução em causa, não estão cobertos por nenhum serviço.

? Custo da solução: com base nos parâmetros definidos, este campo retorna o custo total da solução.

? Nº de bocados: número total dos bocados obtidos na solução. Representa o grupo de blocos de trabalho consecutivos que não estão cobertos pela solução.

? Percentagem de horário coberto: apresenta a percentagem do horário real que se encontra coberto por serviços.

? Duração média dos serviços: apresenta a duração média do total de serviços da solução.

? Duração média dos bocados: apresenta a duração média do total de bocados do problema.

? Nº de etapas: retorna o número de etapas da solução.

Executar Algoritmo

Escolhidos os critérios, o utilizador pode executar o algoritmo para o número de iterações desejado. Para esse efeito, deve-se pressionar o botão Executar. A geração duma solução pode ser parada antes de se atingir o número de iterações definidas.

Para detalhes acerca da parametrização avançada do algoritmo deve consultar o manual do utilizador.


Relatorio

Relatório
No separador Relatório são disponibilizados vários horários. Depois de clicar no botão de um desses relatórios deverá escolher os dados que pretende incluir na geração e algumas opções de geração (se disponibilizado no relatório seleccionado).

Passo a efectuar para guardar o relatório:

1. Na janela Horários por Nó- Relatório, é apresentado um menu na parte superior da janela. Clique no botão Export Report.

2. Escolha a pasta no directório onde pretende guardar o ficheiro.

3. Na janela Export Report, defina o nome do ficheiro no campo File Name.

4. Na opção Save as Type, seleccione o formato que pretende.

Os formatos disponíveis são:


Horarios por Servico de Viatura

Horários por Serviço de Viatura
O relatório Horários por Serviço de Viatura apresenta os horários a efectuar para cada serviço de viatura seleccionado.

Passos a efectuar para obter o relatório de Horários por Serviço de Viatura.

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Horários por Serviço de Viatura.

2. Na janela de Horários por Serviço de Viatura - Selecção deve:
2.1. Seleccionar os Serviços de Viatura para o qual pretende obter os horários
2.2. Para o caso de pretender que o horário de cada Serviço de Viatura inicie numa nova folha, deve seleccionar a opção Quebra de página entre elementos.
2.3. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Horários por Serviço de Viatura - Relatório mostra o relório gerado.


Horarios por Servico de Tripulante

Horários por Serviço de Tripulante
O relatório Horários por Serviço de Tripulante apresenta os horários a efectuar para cada serviço de Tripulante seleccionado.

Passos a efectuar para obter o relatório de Horários por Serviço de Tripulante.

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Horários por Serviço de Tripulante.

2. Na janela de Horários por Serviço de Tripulante - Selecção deve:
2.1. Seleccionar os Serviços de Tripulante para o qual pretende obter os horários
2.2. Para o caso de pretender que o horário de cada Serviço de Tripulante inicie numa nova folha, deve seleccionar a opção Quebra de página entre elementos.
2.3. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Horários por Serviço de Tripulante - Relatório mostra o relatório gerado.


Viagens por Servico de Viatura

Viagens por Serviço de Viatura
O relatório Viagens por Serviço de Viatura apresenta os horários das viagens a efectuar para cada serviço de tripulante seleccionado.

Passos a efectuar para obter o relatório de Viagens por Serviço de Viatura .

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Viagens por Serviço de Viatura .

2. Na janela de Viagens por Serviço de Viatura - Selecção deve:
2.1. Seleccionar os Serviços de Tripulante para o qual pretende obter os horários das viagens.
2.2. Para o caso de pretender que o horário das viagens de cada Serviço de Tripulante inicie numa nova folha, deve seleccionar a opção Quebra de página entre elementos.
2.3. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Viagens por Serviço de Viatura - Relatório mostra o relório gerado.


Viagens por Servico de Tripulante

Viagens por Serviço de Tripulante
O relatório Viagens por Serviço de Tripulante apresenta os horários das viagens a efectuar para cada serviço de tripulante seleccionado.

Passos a efectuar para obter o relatório de Viagens por Serviço de Tripulante .

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Viagens por Serviço de Tripulante.

2. Na janela de Viagens por Serviço de Tripulante - Selecção deve:
2.1. Seleccionar os Serviços de Tripulante para o qual pretende obter os horários das viagens.
2.2. Para o caso de pretender que o horário das viagens de cada Serviço de Tripulante inicie numa nova folha, deve seleccionar a opção Quebra de página entre elementos.
2.3. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Viagens por Serviço de Tripulante - Relatório mostra o relório gerado.


Horarios por Linha

Horários por Linha
O relatório Horários por Linha apresenta os horários a efectuar para cada linha seleccionada.

Passos a efectuar para obter o relatório de Horários por Linha.

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Horários por Linha.

2. Na janela de Horários por Linha - Selecção deve:
2.1. Seleccionar as linhas para o qual pretende obter os horários
2.2. Caso pretenda incluir as viagens em vazio no horário, deve seleccionar a opção Incluir viagens em vazio
2.3. Para o caso de pretender que o horário de cada linha inicie numa nova folha, deve seleccionar a opção Quebra de página entre elementos.
2.4. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Horários por Linha - Relatório mostra o relório gerado.


Horarios por No

Horários por nó
 Previous Top
O relatório Horários por Nó apresenta os horários a efectuar para cada nó seleccionada.

Passos a efectuar para obter o relatório de Horários por Nó.

1. No separador Relatórios é disponibilizado várias opções, clique no botão que diz Horários por Nó.

2. Na janela de Horários por Nó - Selecção deve:
2.1. Seleccionar as nós para o qual pretende obter os horários
2.2. Para o caso de pretender que o horário de cada nó inicie numa nova folha, deve seleccionar a opção Quebra de página entre as linhas de cada nó
2.3. Clicar em Gerar para obter o relatório ou clicar em Cancelar para cancelar a operação.

3. Na janela de Horários por Nó - Relatório mostra o relório gerado.


Controlo


Janela Usado Por
A Janela Usado Por é uma janela que permite listar todos os elementos que usam o elemento previamente seleccionado.

Esta janela pode apresentar um ou mais listas de elementos, dependendo do número de tipos de dados diferentes que podem usar o elemento previamente seleccionado.

(imagem da janela Usado Por)

Nota: Em qualquer lista de elementos apresentada na janela é possível fazer duplo clique sobre um elemento, para ver mais informações.


Metricas de parametros

Métricas de parâmetros